So with my new build that is super duper awesome (view here), I have 32GBs of shiny blue ram to match my sexy motherboard.

Upon installing the necessary drivers and getting my Windows image all set up, I noticed that it only noticed 16GBs of my ram…I mean SPD info showed they were all there and EVERYTHING!!! it just didn’t want to process the extra as usable;(

What changed.? I had performed a BIOS upgrade the night before to make sure everything was cozy and working just right.
What I didn’t know was that for the next two days, this BIOS update would cause me the most pain I’ve ever had with a fairly new build evar!

Long story short, I troubleshooted RAM incompatibilities by reseating about 1000x, messing with DRAM voltages, Memory Map settings, and a slew of other options in my BIOS, clearing RTC, and a few other troubleshooting tricks I’ve learned over the years…..But nothing worked.

So clicking around the net looking for a sign of hope to get me out of this situation, I found a dude who thought his hardware was completely screwed up because of an iGPU problem (I was actually testing without the dedicated GPU and my iGPU didn’t seem to be working either). He posted a link on the last page of the forum thread stating that a dude on hardforums had the solution. Even though it didn’t directly relate to my problem, I thought I would give it a try and perform the bios upgrade from within Windows using the AMI flash utility…why not?

Here are his exact instructions that fixed my core problem of not being able to see all the RAM.

So this is how I fixed my bios which didn't show igpu or turbo ratio (bad ME). Download AMI flash tool from AMI's homepage (since these motherboards have AMI bios/uefi). From the zip file extract: amiflash\aptio\afuwin\64\afuwin64.zip (I guess you run 64bit windows) First, launch afuwingui.exe save your old bios as a backup, just in case click open and browse to your new bios (downloaded from asus for your specific motherboard) in the setup tab, check "program all blocks" click flash and hope for the best. It'll take a while to erase, write and verify reboot This worked for me, after reboot my ME version was updated, and everything works as it should. Bascially this will reprogram your entire eeprom. As any other bios update it's not "safe", not sure if the bios flashback will work if this fails. Anyway, if your alternative is to get a new preprogrammed eeprom I don't see what you have to lose. Link to flash utility: http://www.ami.com/support/downloads/amiflash.zip

You can find his post here (if it’s not there, the above is an exact copy/pasta)..

After doing this with the latest version of the BIOS (which is the exact same one I had used when I did it through the EZ flash utility in the BIOS itself (thanks Asus:|)) and ensuring I hit “program all blocks”, I rebooted to find a fully recognized 32GBs of [email protected]!!!!!!

As “elenhinan” says, this AMI Flash Utility must be rewriting the whole EEPROM as opposed to the EZ Flash utility in the BIOS itself which doesn’t (probably because it would be hard to do while in the BIOS itself ;) This makes sense but still….why should problems like this arise? OMGAWD ASUS!!!!!!!!!

So moral of the story…Do it the hard way.

Also, it’s past 6am. Yes, I stayed up all night working on this. Now it’s time for Homework….that doesn’t deserve to be capitalized.

EOF

Blog Logo

Mario Loria


Published

Image

./scriptthe.net

Because 127.0.0.1 gets old after a while.

Back to Overview